Morpho API downtime due to AWS CloudFront outage
Resolved
Jul 16, 2026 at 8:56am UTC
Internal mitigation propagated and service recovery confirmed.
Affected services
Updated
Jul 16, 2026 at 8:44am UTC
AWS officially acknowledges downtime for CloudFront customers utilizing VPC Origins connectivity.
Affected services
Created
Jul 16, 2026 at 7:54am UTC
Internal observability is detecting a potential AWS CloudFront outage. There are elevated 500 errors across the Morpho API, including Public and Partner endpoints.
Affected services